Almacén con Excel, 5

En este artículo vamos a hacer algunas modificaciones muy sencillas pero útiles a nuestra hoja de pedidos.

Al final del anterior artículo vimos que era laborioso encontrar las posibilidades para obtener el conjunto de pedidos óptimo.

Ahora vamos a agregar unas pocas celdas y fórmulas que nos van a facilitar la tarea.

Diseño

Resultado al finalizar el artículo

Abrir el fichero de Excel con el que finalizó el artículo anterior.

Seleccionar la hoja pedidos y desprotegerla.

Vamos a suponer que la cantidad máxima de pedidos (que no de líneas de artículos) son 10.

En I1 escribir “Pedido” y poner fondo morado.

Seleccionar I2:I11 y poner el fondo en blanco, además en Menú:Formato→Opción:Celdas→Pestaña:Proteger→Bloqueada(desmarcar).

Esta será la sección donde pondremos los pedidos que admitimos a la extracción.

Para no tener que escribir los nombre, vamos a crear una lista que los seleccione de los posibles candidatos de entre los que hay en el total de la extracción (B2:B35).

Seleccionar I2:I11 y Menú:Datos→Opción:Validación→Pestaña:Configuración;Permitir=Lista;Origen=”=$B$2:$B$35”;Omitir blancos(marcar);Celda con lista desplegable(marcar).

Fórmulas

Se agrega una nueva columna, contendrá la cantidad necesaria si el pedido está activo.

Seleccionar la columna E e insertar una nueva.  Es necesario copiar el formato de la columna F (antes E) a la nueva columna E.

En E1 se escribe “Parcial” será el título para esta columna auxiliar.

En E2 se escribe la fórmula “=SI(ESERROR(BUSCARV(B2;$J$2:$J$11;1;0));””;D2)” y se copia en E3:E35.

Ahora las columnas E, F y G mostrarán los datos si el pedido al que pertenecen está seleccionado.

En la celda F2 está la fórmula “=SUMAR.SI($C$2:$C$35;C2;$D$2:$D$35)”, ahora pasa a ser “=SI(ESERROR(BUSCARV(B2;$I$2:$I$11;1;0));””;SUMAR.SI($C$2:$C$35;C2;$E$2:$E$35))

Se ha agregado la condición de que exista el pedido.

Copiar la fórmula en F3:F35.

En F2 la fórmula es “=SI(ESERROR(BUSCARV(C2;areaMaestro;7;0));””;BUSCARV(C2;areaMaestro;7;0))”

Se agrega la condición “=SI(O(ESERROR(BUSCARV(C2;areaMaestro;7;0));ESERROR(BUSCARV(B2;$I$2:$I$11;1;0)));””;BUSCARV(C2;areaMaestro;7;0) )”; Si no encuentra el artículo en el maestro o no encuentra el pedido en las casillas de selección no muestra nada.

Copiar esta fórmula en F3:F35

En H2 había “=SI(G2<F2;”No hay”;””)”.

Ahora escribiremos “=SI(ESERROR(BUSCARV(B2;$I$2:$I$11;1;0));””;SI(G2<F2;”No hay”;””))”; similar explicación.  Copiar este contenido en G3:G35.

Con esto ya hemos conseguido que la hoja de cálculo nos facilite seleccionar un pedido para hacer la previsión de nuestra posible extracción.

Un poco más …

Nos será muy útil para la extracción que muestre al lado del pedido si está o no seleccionado.  Pondremos una marca en la lista de extracción si el pedido debe hacerse.

Seleccionar la columna B e insertar una nueva.

En B1 escribir “Sel”, es el título de esta columna.

En B2 escribir “=SI(ESERROR(BUSCARV(C2;$K$2:$K$11;1;0));””;”*”)”.  Esta fórmula muestra un “*” en aquellos pedidos que están en el grupo de seleccionados para extracción.

Copiar la fórmula en B3:B35 y ajustar adecuadamente el ancho de la columna.

Para finalizar

Pero ya puestos, vamos a rematar con un mensaje que nos dirá si el conjunto de la extracción puede hacerse o no.

En I13 escribir “¿Se puede servir?” y con fondo morado.

En I14 escribir “=SI(CONTAR.SI(H2:H35;”No hay”)>0;”No”;”Sí”)” y color amarillo.

Esta fórmula cuenta cuantas veces aparece “No hay” en G (donde se encuentran los quebrantos de stock), si hay alguno (más de 0) dice que la extracción con estos pedidos no es posible.

Proteger la hoja.

Lo siguiente

Ya hemos seleccionado los pedidos a servir.  En el siguiente artículo conseguiremos una hoja para que el personal de almacén tenga la orden de extracción de mercancía y nos reporte los resultados.

Aquí puede encontrar el fichero Excel resultante.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *