Almacén con Excel, 4

Aspecto de la hoja de pedidos

En este artículo vamos a crear una hoja para facilitar la toma de decisiones a la hora de seleccionar pedidos para extraer mercancía.

Funcionamiento

Tendremos una hoja a la que llamaremos Pedidos.

En ella copiaremos tres columnas previamente preparadas; referencia del pedido, referencia del artículo y cantidad solicitada.

Cada pedido agrupa el total de artículos que un cliente solicita.

Al conjunto de pedidos que se van a servir se le llama extracción.

Beneficios

La hoja nos mostrará si podemos realizar el pedido o por el contrario faltan unidades en el almacén.

Diseño

Abrir el fichero de Excel con el que finalizó el anterior artículo.

Crear una hoja nueva, la llamaremos Pedidos.

Poner el fondo en gris claro.

Poner A1:G1 con fondo morado, son las cabeceras.  Y escribir su título correspondiente:  “Artículo”, “Pedido”, “Ref”, “Cantidad”, “Necesaria”, “Stock”, “Error”.

  • “Artículo”:  Es una columna con fórmula; Busca en el maestro de artículos el nombre que corresponde con “Ref”.
  • “Pedido”:  Se introducirá la referencia del pedido.
  • “Ref”:  Se introducirá la referencia del artículo.  Si al escribirla no aparece su descripción en “Artículo” es porque no existe o se ha escrito mal.
  • “Cantidad”:  Se introducirá la cantidad solicitada en el pedido.
  • “Necesaria”:  Es una columna calculada.  Suma la cantidad total de unidades de ese artículo en el conjunto de la extracción.
  • “Stock”:  Es una columna calculada.  Muestra el stock actual de ese artículo.
  • “Error”:  Es una columna calculada.  Muestra “Error” si se solicitan más unidades de las disponibles.

Poner A2:A35 con fondo amarillo.

Poner E2:G35 con fondo amarillo.

Desbloquear las celdas B2:D35, para que al proteger la hoja estas celdas queden libres.

Desarrollo

En A2 escribir “=SI(ESERROR(BUSCARV(C2;areaMaestro;2;0));””;BUSCARV(C2;areaMaestro;2;0))”

Ahora copiar la fórmula en A3:A35.  Aquí se observan los beneficios de haber dado nombre a las áreas.

En E2 escribir “=SUMAR.SI($C$2:$C$35;C2;$D$2:$D$35)”.  Esta fórmula suma la cantidades solicitadas del artículo en el total de la extracción.  Cada vez que aparezca el artículo se mostrará el total, no tiene mayor importancia.  Copiar en E3:E35.

En F2 escribir “=SI(ESERROR(BUSCARV(C2;areaMaestro;7;0));””;BUSCARV(C2;areaMaestro;7;0))”.  Esta fórmula busca en el Maestro de Artículos el total.  Copiar en F3:F35.

En G2 escribir “=SI(F2<E2;”No hay”;””)”.  Si la cantidad del almacén (F2) es menor que la solicitada para ese artículo (E2) mostrará “No hay”.  Copiar en G2:G35.

Proteger la hoja.

Lo siguiente

Esta hoja muestra “No hay” en los artículos que no se van a poder servir, consecuentemente los pedidos que van a tener que ser apartados de la extracción.

Pero no permite hacer simulaciones fáciles.  Las pruebas implican copiar y pegar cada vez la lista de los pedidos candidatos.

En el siguiente artículo intentaré solventar este problema.

Aquí puede encontrar el fichero Excel resultante.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *